Logo
Click forPleasurecraft Marine parts and manuals!
Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2009
    Location
    Caroga Lake NY, NY, USA
    Posts
    8

    Default "1st: Did PCM use Windsors or

    "1st: Did PCM use Windsors or Clevelands in there marine engines? 2nd: What type of coil do I use to replace the existing coil. I go to the parts store and as soon as I mention Marine engine they get all in a tiz and scratch there heads. I ended up buying a generic 12 volt coil out of desperation. 3rd: I am having a problem with this motor. The engine runs like a champ up to about 1600 RPMs then labors and bucks, spits and hesitates at the 1600 RPM mark. I have totally rebuilt my holley 650 carb and replaced all of the ignition components. The results are always the same. It seems that the misfires above 1400 RPMs are on the right bank of cylinders. I acts to me as if it is starving for fuel, but I have about 7 pounds of fuel pressure at the pump. I am at my wits end and would greatly appreciate any help I recieve. Thanks in advance......"

  2. #2
    Join Date
    Aug 2009
    Location
    Caroga Lake NY, NY, USA
    Posts
    8

    Default "Continued............Is it po

    "Continued............Is it possible that my motor is going into "Limp" mode. Were engines equipt with that feature in 1992 and if so, is there a sensor that can be replaced or checked?"

  3. #3
    Join Date
    Jul 2009
    Location
    Vianen, Utrecht, Netherlands
    Posts
    19

    Default "I have the same problem on 1

    "I have the same problem on 1 of the 2 PCM chevy 305 engines (see Topic)
    Also changed all ingnition components - no effect
    (not the plugwires, will do this tomorrow)
    Swapped carb. from other engine - no effect
    Did not check the fuel pressure yet.......
    Did bypass the fuelsupply with a small homemade fueltank straight onto the fuelpump - No effect
    You can try this to make sure there is no problem with the fuelsupply (flow or bubbles)"

  4. #4
    Join Date
    Jul 2009
    Location
    Vianen, Utrecht, Netherlands
    Posts
    19

    Default Have you checked the advance s

    Have you checked the advance system in the distributor?

Similar Threads

  1. 671 load related overheat
    By ltbawb in forum Detroit Diesel
    Replies: 0
    Last Post: 08-09-2010, 01:25 PM
  2. Not Crusader related but my boat has two of them
    By bobct in forum Crusader Marine Engine Forum
    Replies: 7
    Last Post: 11-16-2009, 12:27 PM
  3. Related problems
    By despy in forum Mercruiser Sterndrive Forum
    Replies: 4
    Last Post: 09-29-2009, 09:30 PM
  4. Non engine related question
    By cehmass in forum Johnson Evinrude Outboard Archive
    Replies: 3
    Last Post: 08-11-2008, 08:02 PM
  5. MERCRUISER 470 RELATED PROBLEMS
    By intrepid in forum Mercruiser Sterndrive Archive
    Replies: 4
    Last Post: 06-29-2007, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •