MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   
Click forPleasurecraft Marine parts and manuals!
Results 1 to 19 of 19
  1. #1

    Default "good luck i'f you can hel

    "good luck i'f you can help me out.i have put new points,cap,butten,wires,plugs,carb,coil,fuel filter,and new check valve at the tank.i drained the fuel and put fresh in it.it runs good up till 2300 and then it starts to fluuter or something.it don't back fire or pop out at the carb or nothing,it runs perfect."

  2. #2

    Default same problem as mine. see the

    same problem as mine. see the post down a few titled "1992 PCM pro boss direct drive sputter at high RPM" what year is your boat? what carb was on before and after? i talked to a guy about this and he thinks mine is the PCM electronic ignition. Will your boat ever go above 2300? I believe the boat gets stuck in "limp" mode which is an electrical safety thing when you have low oil pressure or high temp. check your oil pressure and make sure you're ok there.

  3. #3

    Default "I saw your posting about your

    "I saw your posting about your issues with your engine. I have a 351 Pleasurecraft in my supra, and it stalls on me after I go for about 10 seconds at anything greater than 2k rpm. It started out at 3K, but now it seems to be doing it at anything over 1500 RPM. It starts and idles fine....but it seems to be taking longer to restart between stalls, as if the fuel pump needs time to prime. I had an electrical issue that shorted everything out, so I just replaced the starter, alternator, solenoid, and I had the carburetor rebuilt. When does it all end? I was going to replace the fuel pump, but I wanted to get your input. It sounds like you know a lot and you did a lot of great troubleshooting.
    Any help would be greatly appreciated!!

    Thank you in advance,"

  4. #4

    Default "My nephew and I have identica

    "My nephew and I have identical 1992 PCM Holley carbureted 351's. We both have issues.... His will not go over 3000 rpm but he can open up the throttle. His carb was just rebuilt and no change. Mine runs great 4100 rpm for about 30 seconds then starts to sputter. Back off throttle to 2500 rpm area and all is well. I put a new Edelbrock carb on since I was having idling probs with the Holley. I believe my problem is electrical and possibly the whole electronic ignition is hosed. I think my nephew's is a fuel problem since his runs fine wide open albeit only 3000 rpm. On mine, it doesn't stall it just starts to sputter until i back off to 2500 rpm. Even if I drop to idle it's fine but accelerate beyond 2500 and sputter. If I shut off the engine and restart (reboot the electronic ignition) it will run 4000 for about 10 seconds then back to sputter which leads me to believe i'm getting stuck in limp mode. limp mode is a safety mechanism for the boat when you have low oil pressure or high engine temp. you might check those first. otherwise i think it's an electrical rebuild. that will be my next step. What year is your 351 and what carb is on it?"

  5. #5

    Default "my boat is a 1992 supra and i

    "my boat is a 1992 supra and it has a new carb,fuel pump,wires,cap,butten,lines,fuel filter,coil,my carb was calibrated and dynowed for my engine,timeing is perfect,compression 120 on every cylinder,only 301 hours on it.it will go up to 2600 before it starts to flutter.i took it to a boat machanic and they couldn,t figure it out.i,m starting not to like these motors."

  6. #6

    Default welcome to the club. if you f

    welcome to the club. if you figure it out please post. i truly beleive that your prob (jeffrey smith) is the same as mine and the electronic ignition is hosed (goes into limp mode). that's a pcm custom electronic ignition and i think there's others than you can rebuild with. I'm probably not doing anything more this season.

  7. #7

    Default "Hey guys this is a little fre

    "Hey guys this is a little freaky, our boat started the same thing this year (1992 Supra 351w PCMw/Protec ignition), run it to 3000 for about 7-10 seconds an starts the popping and loading up, shut off the ignition and immediately restart and the same thing all over again. I have rebuilt the carb, replaced the fuel pump, and even went as far as replacing the intake thinking maybe it was sucking in air on the under side. We hooked up a vacuum gage and its at 19 inches at an idle when it hits this threshold or takes a dump mark it dropped to 15 and kept falling. So tonight I have been doing some looking around and found the following upgrade right after I found this thread thought I might drop it to see what you all thought. Here it is http://skidim.com/prodinfo.asp?number=RK107025A"

  8. #8

    Default "I am no expert... but I have

    "I am no expert... but I have owned this boat since new and all symptoms for me point to electrical. This kit takes your electronic ignition back to a standard distributor et. al. I don't know if it would affect performance but at this point performance SUX anyway : )

    I think before I went back to distributor, I'd look to see if there's any replacement electronic ignition system available as the first solution. I really don't like a backwards looking solution if that's PCM's idea. I gotta believe that someone has an electronic ignition replacement for this POS PCM. Also (Jeff Cline) does your boat stay running correctly at lower RPM's if you simply back off the throttle?"

  9. #9

    Default "Yes. its runs fine up to abou

    "Yes. its runs fine up to about 2500-2800 rpm. I am looking at possibly installing a HEI distributor, all you need is power, ground, and tach feed, and it is only about $200 for a complete set up."

  10. #10

    Default "ok, so we talked to skidim.co

    "ok, so we talked to skidim.com today and they gave us three possible scenarios to try 1) disconnect the temp sensor on the intake and start see is problem goes away. 2) disconnect the oil pressure sending unit( there are two of them one goes to the gauge--ours was a blue wire--- and the other goes to the ignition module--ours was a green wire), and start boat to see if problem goes away, and 3) disconnect the knock sensor which is at the back of the left bank cylinder head and give the yellow/tan wire a constant 12v feed and start boat. If the problem goes away after one of these tests you have a bad sensor all of which will throw it into "Limp Mode". Ours however did not fair too well so we are ordering the skidim.com retro ignition kit tomorrow and should have it next week and will report when it is done..."

  11. #11

    Default New distributor retro kit show

    New distributor retro kit showed up today. I will install and get tuned tomorrow and report to you all.

  12. #12

    Default Well the Retro distributor and

    Well the Retro distributor and wiring harness from skidim.com fixed everything. The boat runs strong once again..I recommend it to all who have this problem.

  13. #13

    Default Jeff thanks for the fix update

    Jeff thanks for the fix update !!

  14. #14

    Default Anytime.. Sounds like we have

    Anytime.. Sounds like we have all been fitting this for awhile now. I had to start it again tonight just to make sure it was really fixed.

  15. #15
    Join Date
    Aug 2009
    Location
    Circleville, OH, US
    Posts
    5

    Default "JEFF CLINE: Im glad my wife

    "JEFF CLINE:
    Im glad my wife found this discussion board because I'm about to go nuts trying to figure this 1991 supra 351 protec out! I too have tried the start remove wires test temp and oil sensors and re-start engine all to prove ok! I too have rebuilt the carb engine runs excellent till it hits 150-160 degrees then slam it drops to 1800-2200 rpm "limp mode", I originally thought it to be temp so I replaced the oil pressure switch and low pressure sensor, t-stat, impeller, back flushed the engine and exhaust manifolds and tranny cooler (of which had a leak I fixed that too). The motor is recieving ample water pressure, I did read that another guy had the same problem and replaced plugs and wires (I just did this last year along with the starter and alternator) I will try this tomorrow, the only thing left is the PCM unit it self? How much $ did the unit thru skidim.com cost you - if you dont mind me asking?

    I went as far at to email PCM.

    Their address is:
    Pleasurecraft Marine Engine Company (PCM) 7515 Hill ROAD NW Canal Winchester, Ohio 43110

    I do have their engineering phone # of which I will post later, its not available to me at this posting.

    Thanks,
    Jeff Bache

    PS. ANY EXTRA ADVICE OR POINTERS WOULD BE GREATLY APPRECIATED."

  16. #16
    Join Date
    Aug 2009
    Location
    Circleville, OH, US
    Posts
    5

    Default PCM CORP ENGINEERING PHONE # F

    PCM CORP ENGINEERING PHONE # FOR POST SATURDAY 08/22/2009 @ 6:22PM

    614-837-9001

  17. #17

    Default "It was super easy to install.

    "It was super easy to install. There was a complete harness from the main connection to the Alternator and a complete schematic to hook it up, right down to a new plate to mount the resistor and solenoid to. The unit ran $517.00 delivered second day air.

    Oh and we just got back from our vacation and had the boat on the water running hard for the last 9 days and it ran without a hick-up. The boat actually belongs to a good friend of mine and neither one of us could be happier."

  18. #18

    Default Re: Pleasurecraft marine pcm 351 will not go over 2300

    Great post all, I am having the same issue, the sharing of this experience and guidance is greatly appreciated...

  19. #19

    Default Re: Pleasurecraft marine pcm 351 will not go over 2300

    I may have missed it, but did you verify that the mechanical advance springs in the original alternator were free? Might have saved a mess of money and time if in fact, they were sticking. This would the engine to run poorly at higher RPMs.

Similar Threads

  1. Missing at 2300 rpm
    By shamrock20 in forum Pleasurecraft Marine PCM Forum
    Replies: 2
    Last Post: 08-11-2010, 05:53 PM
  2. Pleasurecraft diesel
    By fathom in forum Pleasurecraft Marine PCM Forum
    Replies: 0
    Last Post: 12-08-2009, 04:58 PM
  3. Cant get over 2300 rpm
    By drevil in forum Pleasurecraft Marine PCM Forum
    Replies: 5
    Last Post: 07-10-2009, 10:50 PM
  4. 351 windsor ford will not go over 2300 rpm
    By jeffrey1678 in forum Pleasurecraft Marine PCM Forum
    Replies: 2
    Last Post: 07-08-2009, 07:52 PM
  5. Pleasurecraft marine outdrive impellar
    By billy hill in forum Pleasurecraft Marine PCM Forum
    Replies: 2
    Last Post: 05-02-2004, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •