Logo
Click for Crusader parts and manuals!
Results 1 to 6 of 6
  1. #1
    Join Date
    Jul 2009
    Location
    springfield, illinois, usa
    Posts
    3

    Default "my starboard engine idles at

    "my starboard engine idles at 800,runs smooth,but really get gassy smelling. I have 454xl with msts ignition. where should I start looking? thanks-fritz"

  2. #2
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,826

    Default ""gassy smelling" - me

    ""gassy smelling" - means the exhaust has unburnt fuel odor?

    Any scan tool info available? If not, check the ECT sensor and connector, maybe the IAT sensor, too."

  3. #3
    Join Date
    Jul 2009
    Location
    springfield, illinois, usa
    Posts
    3

    Default makomark-are the sensors you m

    makomark-are the sensors you mentioned part of the msts system or are they something else?-thanks greg

  4. #4
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,826

    Default ect - engine coolant temp - te

    ect - engine coolant temp - temp gauge for the computer.
    IAT - inlet air temp sensor - air thermometer for the computer.

  5. #5
    Join Date
    Jul 2009
    Location
    springfield, illinois, usa
    Posts
    3

    Default makomark-thanks for the info-y

    makomark-thanks for the info-you've got me going in the right direction.I'm going to work on the boat this weekend and it would really help me to know where these sensors are located on the engine.also if I need new ones where's the best place to shop. thanks again-greg.

  6. #6
    Join Date
    Sep 2008
    Location
    Maryland - USA
    Posts
    6,826

    Default "The IAT should be around the

    "The IAT should be around the "throttle" plate, in the induction system. The ECT could be in the block or the manifold - frankly, I've never worked on one...just going on what could cause the computer to think a richer mixture would be needed.

    The crusader www site has a parts listing for the newer engines...would think that would be a start as that stuff doesn't migrate too often."

Similar Threads

  1. LM360 rough idle with gas smell from exhaust
    By aday_in_nh in forum Chrysler Inboard and Sterndrive Archive
    Replies: 1
    Last Post: 07-28-2008, 12:22 PM
  2. 350 Mag MPI mercruiser Inboard loading up at idle
    By centurioneclipse in forum Other Gas Inboard Mfgs IO and Sterndrive Questions
    Replies: 14
    Last Post: 05-15-2008, 11:04 PM
  3. Gas fume exaust smell no power no idle
    By Matthew Sayers in forum Pleasurecraft Marine PCM Forum
    Replies: 1
    Last Post: 04-20-2007, 08:30 PM
  4. Engine loading up
    By mad mike in forum Archive 2003-2009
    Replies: 0
    Last Post: 08-24-2003, 07:03 PM
  5. Grey 135 loading up
    By Jim Dunn in forum Gray Marine Gas Engine Forum
    Replies: 1
    Last Post: 10-11-2002, 10:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •