Logo
Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2008
    Location
    madeira beach, florida, usa
    Posts
    3

    Default "lost power on westerbeke 7.7,

    "lost power on westerbeke 7.7, found blown capacitor. Changed both capacitors and rectifier but only have 4 volts now. flashed the rectifier as described in tech book but no change. Ideas?"

  2. #2
    Join Date
    Dec 2009
    Location
    Cobb Island, Md., USA
    Posts
    1

    Default "Mark, I have a Westerbeke gen

    "Mark, I have a Westerbeke genset 7.7 KW with no electrical o put.
    What did you find was your problem and solution to fix your similar symptoms?
    Thanks, Jacob
    [email protected]"

  3. #3
    Join Date
    Aug 2008
    Location
    madeira beach, florida, usa
    Posts
    3

    Default "After completely tearing the

    "After completely tearing the 7.7 down, found the insulation on the armature had broken down over the years. I purchased a rebuilt armature and all is good now. Before the voltage went down, it apparently had spiked up after loosing ground and caused a lot of damage to other systems."

Similar Threads

  1. 16 volts too much
    By coffeeguy in forum Mercury Mariner Outboard Archive
    Replies: 3
    Last Post: 07-16-2008, 01:05 AM
  2. 1224 volts
    By bass_bandit in forum Miscellaneous marine engine topics
    Replies: 4
    Last Post: 06-11-2008, 02:13 PM
  3. Volts or Amps
    By oldblue in forum Johnson Evinrude Outboard Archive
    Replies: 3
    Last Post: 04-18-2008, 10:11 AM
  4. My 30L is getting over 16 volts of charge
    By dip_krew in forum Mercruiser Sterndrive Archive
    Replies: 5
    Last Post: 06-22-2006, 01:01 AM
  5. 1989 johnson 175 charges at 165 volts
    By steve quigg in forum Outboard motors archive 2000-2004
    Replies: 1
    Last Post: 06-21-2002, 10:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •