Logo
Results 1 to 8 of 8
  1. #1
    nicolesmith's Avatar
    nicolesmith Guest

    Default "I have a 1987 rinker 2.3 ford

    "I have a 1987 rinker 2.3 ford cobra and it starts and runs great until i run it wide open and then it slowly starts losing power u can watch the speed slowly drop but if u run it half or 3/4 it seems to keep the same speed any one have any ideas on what it could be please help im confused, it starts and runs so good otherwise i dont understand."

  2. #2
    Join Date
    Jul 2006
    Location
    Keswick, Ontario, Canada
    Posts
    1,847

    Default "Could be fuel starvation caus

    "Could be fuel starvation caused by dirty filters, partially clogged fuel tank vent, sticky anti-syphon valve, float adjustment in the carb, weak fuel pump, next time out and it starts to slow down, loosen the fuel tank cap and see if that makes a difference, if it does then your tank vent or line is plugged."

  3. #3
    nicolesmith's Avatar
    nicolesmith Guest

    Default im not sure what its called bu

    im not sure what its called but on the side of the carb their is a line with a fat fitting and inside their is a gold looking filter type thing with a spring. i had that out is it possible that it got put back in backwards or does it matter

  4. #4
    nicolesmith's Avatar
    nicolesmith Guest

    Default I forgot to mention the valves

    I forgot to mention the valves r rattling around 3/4 throttle to if the points arnt set just right would that cause them to rattle

  5. #5
    Join Date
    Jul 2006
    Location
    Keswick, Ontario, Canada
    Posts
    1,847

    Default Not sure if your talking about

    Not sure if your talking about the choke or vacuum break??? Did it work fine before you took that off?

    Do you mean the engine is pinging? Did you replace the points and then did you check/adjust the timing?

  6. #6
    nicolesmith's Avatar
    nicolesmith Guest

    Default well not sure i mesed with it

    well not sure i mesed with it when i broke the pin on the distributor and im not sure if i put it back in rite. i changed the points but i didnt gap them by spec i just got it close. yea seems like the lifters a rattling im so frustrated im not much of a mechanic and i hate to pull it back out of the wter its a long trip to the dock so im tryn fix it myself

  7. #7
    Join Date
    Jul 2006
    Location
    Keswick, Ontario, Canada
    Posts
    1,847

    Default I'd want to check those po

    I'd want to check those points with a dwell meter follwed by the timing before I'd do anything else.

  8. #8
    nicolesmith's Avatar
    nicolesmith Guest

    Default thanx bob ur always a big help

    thanx bob ur always a big help

Similar Threads

  1. Help! Losing power while pushing full throttle
    By Larry123 in forum Nissan Tohatsu Outboard Forum
    Replies: 3
    Last Post: 05-10-2010, 07:01 AM
  2. 1968 20 hp johnson doesnt have full power at full throttle
    By phillipramsey in forum Johnson Evinrude Outboard Archive
    Replies: 6
    Last Post: 07-04-2009, 10:01 AM
  3. Suzuki DT25 losing power at full throttle
    By arringdd in forum Suzuki Outboard Archive
    Replies: 1
    Last Post: 06-19-2008, 12:49 AM
  4. 68 merc losing rpmbs at full throttle
    By Roy Davis in forum Mercury Mariner Outboard Archive
    Replies: 2
    Last Post: 03-26-2006, 11:59 PM
  5. Replies: 2
    Last Post: 02-20-2006, 07:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •