Logo
Results 1 to 3 of 3
  1. #1

    Default " My 1989 150 horse Force turn

    " My 1989 150 horse Force turns over well, however I do not hear or see (when I remove a plug) a spark. Is there any obvious thing I should check? I do believe that the kill switch is working as intended however the symptons seem like something similiar could be at fault- Thanks very much. "

  2. #2
    Join Date
    Mar 2003
    Location
    Posts
    50

    Default read the post that saya stato

    read the post that saya stator check on 90 hp force i think thats what it may be

  3. #3

Similar Threads

  1. force 40 not firing. need help!
    By bayliner46 in forum Chrysler Force Outboard Forum
    Replies: 3
    Last Post: 08-04-2010, 03:06 PM
  2. 76 Evinrude 85 horse Firing only on 2 cylinders
    By Hellrazor in forum Johnson Evinrude Outboard Forum
    Replies: 2
    Last Post: 05-28-2010, 08:25 AM
  3. 1989 Force 85 hp firing problem
    By lisanterr in forum Chrysler Force Outboard Forum
    Replies: 3
    Last Post: 04-02-2010, 10:43 PM
  4. 95 70hp force #2 cylinder not firing
    By cbrown7142 in forum Chrysler Force Outboard Archive
    Replies: 4
    Last Post: 05-10-2007, 06:28 PM
  5. 1991 Force 120 2 cylinders not firing
    By gary_lutchansky in forum Chrysler Force Outboard Archive
    Replies: 2
    Last Post: 02-07-2007, 07:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •