Logo
Results 1 to 3 of 3
  1. #1
    Al Ebstein's Avatar
    Al Ebstein Guest

    Default "Port engine runs at 75psi whi

    "Port engine runs at 75psi while starboard runs at 115-125psi at WOT. It is either real or I have a sensor or gage problem on starboard engine. This engine was at 75psi before an oil change. Went to 120psi right after the oil change. Port engine at75psi before and after the oil change. Both engines run well, no temp problems no smoke they sound the same too.

    Has anyone ever run into this before? and if so what was found t be the problem."

  2. #2
    Join Date
    Dec 2005
    Location
    Vancouver , British Columbia , Canada
    Posts
    129

    Default take the senders and switch th

    take the senders and switch them from one engine to the other and see what it does. I have found that the senders that Yanmar use have been not all that accurate. Try that and see what happens.
    Guages are usually good. Then not with out faults either. In most cases it is the senders.
    Ron

  3. #3
    Join Date
    May 2006
    Location
    pensacola, fl., u.s.a.
    Posts
    1,366

    Default "first, verify that the pressu

    "first, verify that the pressure is real. switch sensors as advised, or use a mechanical O.P. guage. (my preference) most of the larger yanmars have an oil pressure regulator. it may be sticking. normally it would be located in the bottom of the oil cooler. large plug with spring and plunger above. definately get a service manual if you are going to do any maintainance or repairs yourself. the yanmar factory manuals are excellent and very easy to understand."

Similar Threads

  1. high oil pressure
    By dpcub in forum Mercruiser Sterndrive Forum
    Replies: 13
    Last Post: 10-27-2010, 01:28 AM
  2. Yanmar 6LY lost oil pressure
    By slimpick99 in forum Yanmar
    Replies: 0
    Last Post: 05-11-2010, 10:11 PM
  3. High oil pressure
    By proteus in forum Ford Lehman
    Replies: 3
    Last Post: 10-01-2009, 11:15 AM
  4. High Oil Pressure
    By ezuskin in forum Chrysler Inboard and Sterndrive Forum
    Replies: 1
    Last Post: 06-21-2009, 12:04 AM
  5. High oil pressure
    By cowpowr in forum Volvo Penta Gas Archive
    Replies: 1
    Last Post: 07-15-2007, 01:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •