MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   
Results 1 to 3 of 3
  1. #1
    Doug Walker's Avatar
    Doug Walker Guest

    Default " I was just wondering if anyo

    " I was just wondering if anyone has any advice for me besides getting a new engine. I have a 1985 125 Force. The problem I'm having is the engine will barely crank and when it does the batter cables to the ignition switch get so hot the rubber starts to melt. I think the starter has gone and I have one on order. Also, when I have to plugs out the engine turns no problem. Well, if anyone has any advice for me please let me know. "

  2. #2
    Join Date
    Feb 2001
    Location
    Central West Florida
    Posts
    11,734

    Default "Doug.... The Force engine is

    "Doug.... The Force engine is not my line of expertise, however your problem is typical of a wire or cable that is either wired improperly or has a loose or corroded connection somewhere. Did this engine starting system ever work as it should, and this problem has just surfaced, or did you just get this engine and discover that this problem existed right off the bat...or have you changed something, then had this problem take place?

    Joe[img][/img]"
    Our questions require answers. If you refuse to answer our questions, how can we answer yours?

  3. #3
    Doug Walker's Avatar
    Doug Walker Guest

    Default " I have not used the engine i

    " I have not used the engine in a few years and right before I stopped using it the starter would seem to struggle to crank the engine and then it would turn over. I never noticed the heat on the cable until it would not turn over. Also, when I did have the engine working sometimes the teeth on the starter would not lift right away to make contact with the flywheel. Thanks for getting back to me. "

Similar Threads

  1. Force 120 Ignition Problems
    By remiller in forum Chrysler Force Outboard Forum
    Replies: 0
    Last Post: 09-07-2009, 09:14 PM
  2. Chysler force 125 ignition problems
    By bayliner21 in forum Chrysler Force Outboard Archive
    Replies: 1
    Last Post: 08-24-2008, 07:29 PM
  3. 88 force ignition system
    By bandbautowurks in forum Chrysler Force Outboard Archive
    Replies: 4
    Last Post: 12-27-2007, 11:21 AM
  4. HELP 1986 force 50 ignition coil
    By whitedakota in forum Chrysler Force Outboard Archive
    Replies: 4
    Last Post: 09-03-2007, 01:08 PM
  5. Force 85 hp ignition timing
    By maurod in forum Chrysler Force Outboard Archive
    Replies: 2
    Last Post: 08-10-2007, 09:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •