Logo
Results 1 to 2 of 2
  1. #1
    markv's Avatar
    markv Guest

    Default " engine is in project sailboa

    " engine is in project sailboat. last haulout in 12/03.raw water cooling setup. engine seems to run fine but no water coming out of transom exhaust thruhull. impeller looks good. the boat has all new exhaust system aft of engine to thruhull. removed hose at thermostat housing and cranked the engine, hose from pump to t-housing was very slow to fill. how much time doe's it take or should it take to run water through the cooling system? what else should i be looking for? "

  2. #2
    Join Date
    Sep 2002
    Location
    Posts
    118

    Default " i owned a 1972 atomic 4 that

    " i owned a 1972 atomic 4 that overheated because it was plugged with rust and sludge.my solution was to disconnect the inlet and out let lines ,remove the thermosthat and add longer hoses to a 5gal.pail filled with boiler cleaner and ran the engine reciculating the fluid.i did this for about an hour,when engine starts overheating shut it down until cool then restart ,continue till water is somewhat clean [no rust].flush engine with fresh water and reasasemble .this worked for me. "

Similar Threads

  1. Engine overheating
    By the dog house in forum Marine Power Engine Forum
    Replies: 4
    Last Post: 06-16-2010, 05:41 PM
  2. Engine overheating
    By rreining in forum Mercury Mariner Outboard Forum
    Replies: 2
    Last Post: 03-16-2010, 02:42 AM
  3. Overheating Engine
    By boatdude76 in forum Marine Power Engine Forum
    Replies: 0
    Last Post: 06-14-2008, 06:10 PM
  4. Atomic4 replacement
    By pisalainen in forum Universal and Westerbeke
    Replies: 0
    Last Post: 03-30-2007, 01:31 PM
  5. Overheating Engine
    By stew in forum Other Diesels Mfgs and General Diesel Questions
    Replies: 0
    Last Post: 10-18-2006, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •