Logo

Search:

Type: Posts; User: jclays

Page 1 of 4 1 2 3 4

Search: Search took 0.00 seconds.

  1. Thread: batteries

    by jclays
    Replies
    4
    Views
    88

    batteries

    Good Afternoon
    Time for new batteries. Crusader 5.7 (350ci)
    I am currently using the West Marine Dual-purpose batteries . CCA 650 MCA 750. Reserve min 150.
    Interstate has a much better price on...
  2. Replies
    21
    Views
    919

    Re: Running too warm?

    thermistor?
  3. Replies
    21
    Views
    919

    Re: Running too warm?

    Going to have to go to the boat and check the access. I think the manifolds will be in the way of the plug removal and temp sender installation. The block has a plug about half way down mid block...
  4. Replies
    21
    Views
    919

    Re: Running too warm?

    If I was looking in a car engine bay... passenger or driver side?
    thanks
  5. Replies
    21
    Views
    919

    Re: Running too warm?

    I do not see anything on the head itself however there is a brass threaded plug on the right side of the engine block (viewed from the rear looking forward) centered below the center exhaust ports...
  6. Replies
    21
    Views
    919

    Re: Running too warm?

    I wish there were provisions on the intake or the T stat housing for the sending unit. there is a Tee that feeds from the exhaust manifold to the T stat housing. One end is capped. I can try...
  7. Replies
    21
    Views
    919

    Re: Running too warm?

    Replaced a pulley and used 1/4 inch spacer to extend out the pulley on the harmonic balancer. Seems to have worked it was out of alignment put new alternator with the new motor I installed. The new...
  8. Replies
    21
    Views
    919

    Re: Running too warm?

    Found the trouble. Belt that drives the engine circulating water pump was damaged and loose. Bought a new belt and installed it however it starts running true after about a minute the belt...
  9. Replies
    21
    Views
    919

    Re: Running too warm?

    I need to find a quality for salt water use thermostat. The ones that look like a stainless/brass mix get rusted up in about a year or so. With the stay at home quarantine I have plenty of time to...
  10. Replies
    21
    Views
    919

    Running too warm?

    Good morning
    Almost one year ago this month I replaced my port side engine with a brand new base 350 marine engine long block. She's been running good but had not gone very far. Unfortunately due...
  11. Replies
    2
    Views
    106

    seized 1978 70hp Merc

    Good evening
    I was given a 1978 70hp outboard by a friend who just wanted it out of his shop. Said it ran fine about 5 years ago. He stored it in his shed without starting it for all that time and...
  12. Replies
    4
    Views
    734

    Re: 1986 DT4 2stroke idle

    Ya with one turn out i'm leaking fuel. Will turn it back in closed. Will remove the carb again not convinced its 100 percent clean.
  13. Replies
    4
    Views
    734

    Re: 1986 DT4 2stroke idle

    Thank you
    These are on the side of the carb. There are also 2 on the fuel bowl. The one on the bottom is a drain and for disassembly what is the one on the side of the bowl with a spring on the...
  14. Replies
    4
    Views
    734

    1986 DT4 2stroke idle

    Good morning
    I recently picked up a discarded DT4 2stroke. Cleaned out the carb and gas tank, replaced the fuel lines and got her started. The motor will only idle if the choke is partially engaged....
  15. Replies
    12
    Views
    1,471

    Re: Oh oh lots of steam

    In the thru hull fitting. the sea cock was clear and operational. Seems like the up tube between the clamshell and the sea cock.
  16. Replies
    12
    Views
    1,471

    Re: Oh oh lots of steam

    It was some sort of white calcification very hard but crumbled when I started jabbing it with a large screw driver. I was going to call my diver to pay better attention on the intakes and thru hulls.
  17. Replies
    12
    Views
    1,471

    Re: Oh oh lots of steam

    Fixed. Removed intake hose from they hull. Opened shutoff valve. No water. Probing with large screw driver and felt an obstruction. Started working the screw driver and broke the obstruction. Plenty...
  18. Replies
    12
    Views
    1,471

    Re: Oh oh lots of steam

    Hoses of of the elbows?? Exhaust ?
  19. Replies
    12
    Views
    1,471

    Re: Oh oh lots of steam

    Need to find why no water. two weeks ago ran great. Good water flow. Two weeks latter started engine to warm up and no water flow. Both pumps spin with the engine running. Nothing unusual. Need to...
  20. Replies
    12
    Views
    1,471

    Oh oh lots of steam

    Warming up my twin 350ís while cleaning the boat. Engines running at 2000rpm for a few minutes. Running smoothly. Turned around and saw a lot of steam coming from starboard exhaust. No water exiting...
Results 1 to 20 of 70
Page 1 of 4 1 2 3 4