MarineEngine.com - Your online store for all types of marine engines and boat parts.
PHONE ORDERS
Monday - Friday
9:00 AM - 5:00 PM EST
Click for TOLL-FREE Number
Online Checkout
Special $9.95 Flat Rate Shipping
(800) 209-9624 | Home | Contact | Shipping | Returns | Cart View your shopping cart.
Part Number Search
Shop by engine/drive part number.
Original & matching parts for sale.
Manuals & Accessories
Shop by description, item number
or manufacturer's model number.
Boat Repair Forum Boat Repair Forum   Boat Video Gallery Video Gallery
   

Search:

Type: Posts; User: trooper

Search: Search took 0.02 seconds.

  1. Replies
    2
    Views
    560

    "Thanks Joe, I have not checke

    "Thanks Joe, I have not checked the spark because it started and seemed to run good. However, the dry looking plug bothered me especially since there is just one carburetor giving oil to both...
  2. Replies
    2
    Views
    560

    "I have an Evinrude 1976 model

    "I have an Evinrude 1976 model 25602E 25 hp with about 145 psi compression on both cylinders. The top plug looks dry with little oil residue and the bottom plug looks somewhat wetter. What may be the...
  3. " My engine seems to bog down

    " My engine seems to bog down on accelerating from idle when the carbs. butterflies and timing advance move at exactly the same time. This is what the books say the setting should be, but if I set...
  4. "Thank you Joe! This is a 60 d

    "Thank you Joe! This is a 60 degree Looper engine, but I think you are right about the fittings. They appear to me to be pressed into the block behind the plastic manifold. I plan to go to the dealer...
  5. " I have 2 pluged fitting/scre

    " I have 2 pluged fitting/screens on the port side recirculation system. I have tried to clean them, but cannot get them clear. In fact I poked a hole in one of the screens or plastic material....
  6. " I have 92 Johnson 150 VJELAN

    " I have 92 Johnson 150 VJELANC motor. The trim motor is not working all the time. After checking and replacing relays, wiring etc., I discovered the trim motor needs brushes. My local parts dealer...
  7. Thread: H2OPressure

    by trooper
    Replies
    3
    Views
    158

    " Thanks you Joe, I had not th

    " Thanks you Joe, I had not thought of that. I do remember looking to see if water was comming out of the telltale and it was , but I did not check for a partial restriction. Should I just disconnect...
  8. Thread: H2OPressure

    by trooper
    Replies
    3
    Views
    158

    " Strange things... Last boati

    " Strange things... Last boating season the water pessure on my 92 Johnson 150 was 6-8 psi at idle and 15-25 psi while running wot. Now I put the boat in the water this season and noticed the...
  9. " Joe, I have posted several t

    " Joe, I have posted several times regarding my idle problem. My VJ150ELANC has 110psi compression an all cylinders. I started out fine this year's season until I performed what I thought was...
  10. " Joe thanks for the help. Doe

    " Joe thanks for the help. Does this mean there is anything special or different about this motor ?
    Thanks in advance,
    Trooper "
  11. " What year is my motor? Model

    " What year is my motor? Model number VJ150ELANC. This does not seem to work with the INTRODUCES scheme. Can anyone help explain this to me?

    Thanks,

    Trooper "
  12. Replies
    3
    Views
    134

    " This is exactly what the sti

    " This is exactly what the sticker indicated on the transom port side motor mount.

    Thanks for the reply,

    Trooper "
  13. Replies
    3
    Views
    134

    " What year is my motor? Model

    " What year is my motor? Model number VJ150ELANC. This does not seem to work with the INTRODUCES scheme. Can anyone help explain this to me?

    Thanks,

    Trooper "
  14. " Joe thanks a million or at l

    " Joe thanks a million or at least $8,000 worth. I have owned the boat and motor for about 4.5 years and it is never been in salt water to my knowledge. The boat did run great about 3 weeks ago,...
  15. " I put the boat in the water

    " I put the boat in the water this weekend, but it would not stay running. When first starting it would idle fine for adout 30 sec and begin to decrease RPM and then spit sneeze once and cut off....
Results 1 to 15 of 15