Logo
Page 1 of 120 1231151101 ... LastLast
Threads 1 to 50 of 5964

Forum Home: Mercruiser Sterndrive Forum

Sub-Forums Threads / Posts  Last Post

  1. Forum Actions:

    Forum Statistics:

    • Threads: 6,299
    • Posts: 41,315
    • Replies: 7
    • Views: 24,124
    09-24-2017, 02:09 AM Go to last post
  1. 1999 4.3 with cracked block or head

    Started by mike.l, 10-11-2018 08:32 PM
    • Replies: 16
    • Views: 643
    Today, 04:39 PM Go to last post
  2. Manifolds and Risers

    Started by Jakwi, Today 11:27 AM
    • Replies: 4
    • Views: 33
    Today, 01:45 PM Go to last post
  3. Leaking transom after service.

    Started by mattryan, 01-17-2019 04:46 PM
    • Replies: 15
    • Views: 153
    Yesterday, 07:05 PM Go to last post
  4. no drive

    Started by kunbarrie, 12-30-2018 09:26 PM
    • Replies: 14
    • Views: 371
    01-19-2019, 12:53 AM Go to last post
    • Replies: 7
    • Views: 90
    01-17-2019, 05:42 AM Go to last post
    • Replies: 6
    • Views: 239
    01-15-2019, 01:40 PM Go to last post
  5. starter trouble

    Started by qed, 01-03-2019 06:34 PM
    • Replies: 18
    • Views: 329
    01-11-2019, 09:04 AM Go to last post
  6. Mercruiser Alternator Help please

    Started by Keithm18, 12-29-2018 01:22 PM
    • Replies: 2
    • Views: 170
    12-29-2018, 02:28 PM Go to last post
  7. 5.7 vortec mercruiser intake manifold

    Started by trimta, 12-26-2018 06:43 PM
    • Replies: 7
    • Views: 221
    12-28-2018, 11:31 AM Go to last post
  8. shot impeller?...plastic bag overheating

    Started by Pluterday, 12-23-2018 08:02 AM
    • Replies: 12
    • Views: 270
    12-27-2018, 11:01 PM Go to last post
    • Replies: 3
    • Views: 165
    12-24-2018, 10:09 AM Go to last post
  9. Winterizing

    Started by boater7, 12-04-2018 09:19 PM
    2 Pages
    1 2
    • Replies: 43
    • Views: 809
    12-15-2018, 07:58 AM Go to last post
  10. 1989 Mercruiser 3.0 inboard

    Started by Mrpiano45, 12-09-2018 08:25 PM
    • Replies: 5
    • Views: 213
    12-10-2018, 07:24 PM Go to last post
  11. Runs rough at idle

    Started by Jakwi, 12-08-2018 03:18 PM
    • Replies: 16
    • Views: 265
    12-10-2018, 05:24 PM Go to last post
  12. Merc Inboard 454 Gen VI Flywheel issue?

    Started by redhook98, 11-29-2018 08:52 AM
    • Replies: 10
    • Views: 334
    12-07-2018, 06:31 PM Go to last post
    • Replies: 14
    • Views: 362
    12-04-2018, 04:51 PM Go to last post
  13. Delco EST wiring

    Started by wufibugs, 11-08-2018 06:21 PM
    • Replies: 2
    • Views: 320
    12-02-2018, 01:04 AM Go to last post
    • Replies: 6
    • Views: 318
    11-24-2018, 10:31 AM Go to last post
    • Replies: 3
    • Views: 249
    11-23-2018, 09:52 PM Go to last post
  14. Installing a whip hose and cap on a Merc 454

    Started by MEG, 11-22-2018 04:48 PM
    • Replies: 4
    • Views: 252
    11-23-2018, 12:10 PM Go to last post
  15. NO serial numbers?

    Started by trimta, 11-20-2018 07:39 PM
    • Replies: 9
    • Views: 387
    11-22-2018, 08:16 AM Go to last post
  16. Antifreeze in cylinders in 78' Merc 454

    Started by 42Uniflite, 11-21-2018 03:19 PM
    • Replies: 1
    • Views: 237
    11-21-2018, 05:43 PM Go to last post
    • Replies: 23
    • Views: 648
    11-21-2018, 02:00 PM Go to last post
  17. 351 233 merc leg

    Started by 1Chester, 11-17-2018 07:59 PM
    • Replies: 1
    • Views: 244
    11-18-2018, 08:18 AM Go to last post
  18. Help for mike on engine block please

    Started by mike.l, 11-15-2018 07:44 PM
    • Replies: 3
    • Views: 299
    11-16-2018, 03:18 AM Go to last post
    • Replies: 2
    • Views: 288
    11-15-2018, 11:40 AM Go to last post
    • Replies: 12
    • Views: 379
    11-13-2018, 11:49 AM Go to last post
  19. Gear Housing/Driveshaft Housing Mating

    Started by Looking4Help, 11-08-2018 09:09 PM
    • Replies: 4
    • Views: 305
    11-10-2018, 10:23 AM Go to last post
  20. 5.7 350 MAG MPI -2003 Starting Issue

    Started by abl1111, 11-07-2018 06:37 PM
    • Replies: 3
    • Views: 339
    11-09-2018, 08:43 AM Go to last post
  21. Alpha One Water Pump

    Started by edcourter, 10-25-2018 12:01 PM
    • Replies: 15
    • Views: 619
    11-08-2018, 07:44 PM Go to last post
  22. Raw Water Pump

    Started by Ahenderson, 11-06-2018 01:36 AM
    • Replies: 7
    • Views: 383
    11-07-2018, 10:19 AM Go to last post
    • Replies: 2
    • Views: 334
    11-06-2018, 12:58 AM Go to last post
    • Replies: 2
    • Views: 340
    11-05-2018, 05:24 PM Go to last post
  23. Mercruiser throttle question

    Started by Hybrid, 11-04-2018 06:41 PM
    • Replies: 3
    • Views: 310
    11-05-2018, 09:01 AM Go to last post
  24. power tilt is reversed ???

    Started by Classic78, 10-31-2018 10:17 PM
    • Replies: 1
    • Views: 309
    11-01-2018, 08:55 AM Go to last post
  25. engine won't rev

    Started by qed, 09-10-2018 12:31 PM
    • Replies: 10
    • Views: 631
    10-29-2018, 10:25 AM Go to last post
  26. Help with 4.3L MPI draining

    Started by pharmacist25, 10-21-2018 12:04 PM
    • Replies: 8
    • Views: 442
    10-22-2018, 03:16 PM Go to last post
    • Replies: 11
    • Views: 673
    10-19-2018, 05:30 PM Go to last post
  27. Power trim tilt hose

    Started by Jwc, 10-18-2018 05:25 PM
    • Replies: 1
    • Views: 326
    10-18-2018, 10:59 PM Go to last post
  28. Exhaust hotter on one side

    Started by Donzi indian laker, 09-29-2018 10:33 AM
    • Replies: 8
    • Views: 507
    10-18-2018, 05:41 PM Go to last post
  29. Ignition beeping

    Started by jeffronin3, 10-16-2018 12:15 PM
    • Replies: 5
    • Views: 406
    10-17-2018, 07:46 AM Go to last post
    • Replies: 3
    • Views: 304
    10-15-2018, 04:28 PM Go to last post
    • Replies: 9
    • Views: 456
    10-15-2018, 11:21 AM Go to last post
  30. mercruiser upper-lower unit swap issue

    Started by shadycreek007, 10-14-2018 01:43 PM
    • Replies: 4
    • Views: 377
    10-14-2018, 07:18 PM Go to last post
  31. Sheen in water

    Started by Chrisvr6, 10-12-2018 09:43 AM
    • Replies: 6
    • Views: 434
    10-14-2018, 12:56 PM Go to last post
  32. Arrow how fix port Temperature sensor error 8.2 MAG

    Started by RelaxBoat, 10-08-2018 06:28 PM
    • Replies: 6
    • Views: 459
    10-14-2018, 02:45 AM Go to last post
    • Replies: 1
    • Views: 335
    10-13-2018, 11:08 AM Go to last post

Page 1 of 120 1231151101 ... LastLast

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 10 replies or 100 views
Hot thread with unread posts
More than 10 replies or 100 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •