PDA

View Full Version : Motorguide wireless foot pedal issue, please help!



pohlersc
05-15-2020, 08:43 PM
Hoping someone can assist me! I have a motorguide wireless trolling motor, model 970100050. I connect the motor to the battery and nothing on the foot pedal beeps. When I disconnect the positive or negative cable, the trolling motor beeps. I can also hook the motor up and the “test battery gauge” on the motor itself works. I replaced the foot pedal battery but I’m not sure how to program the pedal to the motor. Can someone please provide any tips to try? Thank you!

daves69
05-15-2020, 10:53 PM
Motoguide owner manuals are available for download. It include instructions for resetting the foot pedal and clearing previous codes...……….
https://www.motorguide.com/us/en/owners-resources.html

pohlersc
05-16-2020, 05:56 AM
Motoguide owner manuals are available for download. It include instructions for resetting the foot pedal and clearing previous codes...……….
https://www.motorguide.com/us/en/owners-resources.html

i tried to both reset the codes and activate the foot pedal, per the manual instructions. Neither of them worked. Sometimes when I hook the motor up to the battery, the prop will spin slowly but the foot pedal doesn’t work. Is there something else I’m missing? Or maybe it’s time for a new pedal?

daves69
05-16-2020, 07:59 PM
Personally I like the pendant better
although I have both. I have never had an issue with either other than the battery. I would not like to be the one that told you to run out and get a new pedal and you find it's the motor electronics. You might try to find another boater in the area with a pedal set or pendant they might allow you to test with. Other than that there are other forums you may find more experience and traffic on such as...……………..
https://forums.iboats.com/forum/boat-repair-and-restoration/electrical-electronics-audio-and-trolling-motors