PDA

View Full Version : Mercury 35 2 cyl with remote controls. Idle not returning to idle stop screw after throttling.



dantabletop
09-07-2019, 10:55 AM
I'm sure this is an easy fix, I'm just clueless and not sure where to start.

It idles high after coming back to idle from a higher throttle. I concluded that its because it's not returning back to the idle stop screw. However I'm able to push it back manually by physically moving it to the idle stop screw - only then will it return to the idle screw.

It seems like possibly somethimg is loose. I just don't want to monkey around and break anything. Perhaps need to tighten a nut on a lever or perhaps throttle cable needs to be tightened?

I'm at work now, but can provide some pics later when I get home.

I figure I should fix this asap, as when putting it into gear - it bucks pretty hard due to the high RPMs

Thanks much

flyingscott
09-07-2019, 11:50 PM
If this is a remote control model tighten the throttle cable up so it pulls it.to the stop.

dantabletop
04-06-2020, 01:52 PM
I had a lot to deal with so now only getting started on fixing this before I put the boat in the water.

I'm really not sure how to remedy this. I'm pretty clueless and not really sure how to tighten the throttle as dumb as that may sound.

After giving higher throttle - and returning to idle - it doesn't go all the way back to the idle stop screw unless I push it back manually.

https://www.youtube.com/watch?v=EEG_UKskSu4

Crappy video, I can take a better one if need be and take pictures

dantabletop
04-06-2020, 05:06 PM
Nevermind. I figured it out. Tightening the barrel to tighten the throttle cable fixed it.