View Full Version : Motorguide xi5 issue

04-13-2019, 03:46 PM

Since the motorguide support line is so "helpful" I hope I can get a better answer here. About 10 months ago I bought motorguide xi5 36v version. The motor is hooked up to my lowrance elite 9ti. The motor worked grate but I soon noticed that while in anchor mode the motor would randomly go out of anchor with a faint beep. I didn't think much about it until it happened the for the 20th time. I'm not sure 100% sure what caused, but I suspect it was a bad gps module. Worth to mention is that I could activate anchor mode instantly after I went out of anchor (standby). So what I tryed at first was to recalibrate keel positioning and compas calibration. This did not work so I tryed running the motor disconnected from the nmea 2000 network, but again it still happened.

I then connected the shop where I purchased the motor and I was recommended to check for voltage drop and I bypassed the fus, still the motor dropped out and I had fully charged battery.

I went back to the shop and we agreed to open a guarantee case for replacing the main circuit board. We also made an agreement that I would replace the parts since I have the calcifications for this as I do this type of work for a living. Anyway I received the circuit board and replaced it. And quickly noticed that MGs quality control is lacking a bit since the silicone molding compound were cracked acound some of the out going connections, so I sealed that with silicone grease. I went out a few hours testing the motor and off course the anchor mode issue were still occruing. Worth to mention that it randomly occurred some times after an hour and sometimes after two hours.

Again I connected the shop and this time I requested to try with a new GPS module. Few days later I received the new GPS module. Took the motor on to the workbench and replaced the module. I noticed that the new GPS module were different than the old GPS module. I asked the shop and he told me that this was the new module that were for both the xi5 and the xi3. The next day I went out in high hopes and the motor seemed to work fine and I was really happy, but I soon noticed that something were wrong.

There is a auto pilot function that comes with the motorguide connected to the lowrance plotter. Before I could choose a spot and the motor would gladly move me to the spot. Before you tell me to adjust the settings I have tryed to adjust the end of move functions (standby, anchor here, heading lock) but the motor starts to move but as soon it reaches the setpoint it just keeps going, no not in a heading lock because it will start to go in a circle. I then contacted the shop again and I replaced the GPS module and main circuit board too this time.

When I went out to test the motor again it still did the same ting when it reached the end point. So I desided to do a hard reset on the elite 9ti without any luck. Again it is worth to mention that the plotter has the newest update. I also took out the new GPS module and put the old one back and the autopilot function were working flawlessly except the motor going out of anchor.

So now I'm lost. I have also done recalibration on the motor after every module replacement I have done. I do not have a paddle control I only use the wireless control and the lowrance interface.

Im very disappointed in MGs support. I only got the standard suggestion which is stated in the manual regarding the calibration, even though I specified the issue in detailed description. So I then called them on phone which is a bit hard considering I'm a Norwegian, but I was meet with a lady that did not want to help me. I tryed explaining that I found it very odd that I have replaced the GPS module two times and still had the same problem. It's like there is an issue with MGs new GPS module...damn with all the fuel and time this has taken I'm starting to regret spending 3k on this motor when I had the chance to by the minkota...

Hopefully someone here can help me with this would greatly appreciate it.

The next stage is to deliver the motor to a local mercury certified dealer for repair, but I'm pretty sure they will end up with the same result as me.

05-20-2019, 10:03 PM

mine dose the same thing.

i have mine hooked to an hds 2 lowrance with the link.. in heading hold mode it will all of a sudden just go bezerk and shut off heading hold go to stand by and throttle way up in whatever direction.

in anchor mode it just drops anchor mode and goes to stand by and I will be drifting with lines getting all tangled. when it was at its worsed I did notice that we had 4 cell phones on board seems kind of fishy.

I think its a gps issue but not sure how to resolve. wondering if I can add external gps antenna if this would help. also wondering if the power cables running to the front of the boat from the batteries not being shielded might be an issue..

later andrew k

05-21-2019, 11:25 AM

i dont know if this will help but i am going to try it. there is a gps patch download for my lowrance hds 2. seems that every 20 years the gps runs to 0 or somthing like this and the softwere needs changed on the gps.. i know its not the gps unit on the motorguide but worth the try..