PDA

View Full Version : John Deere 4045TFM CAN Bus problem, Please Help.



Bartonman
08-16-2013, 08:21 PM
The engine starts and idles only. When the master control panel is the only panel connected, the Murphy Powerview indicates CAN Bus Failure. And the other gauges on the panel only indicate they are powered. I checked the voltage on the three wire CAN Bus system and the yellow to ground is 2.5 volts DC and the green to ground only reads 1.74 volts DC (supposed to be 2.5 also). There is no continuity between green and ground or yellow and ground. The resistance between CAN High and CAN Low is 61.2 ohms. The terminating resistors both checked out at 121 ohms each.When I plugged the second stations control panel to the wiring from the master panel, the Murphy Powerview does not indicate a CAN Bus failure, but instead it indicates as if it is receiving data from the ECM. It indicates a fault code of SPN 29 FMI 4, which is "Secondary Analog Throttle Signal Out of Range Low". The only Gauge on the cluster that indicates any information is the battery voltage, which is 12.8 volts. When I disconnect the secondary control panel it goes back to CAN Bus failure. The control panels are new, as is the harness from the control panel to the engine wiring harness. The engine has approx 104 hours on it. The engine harness came with the engine. Any idea of what is going on here? I have zero experience with CAN Bus and only know what I have studied while trying to troubleshoot this problem.

glen_adolph
09-02-2013, 11:02 PM
CAN high(yellow) should be 2.6vdc and CAN low should be 2.4vdc in a perfect world. Check contunity on green CAN bus to ground. It should be OL. Check for a bad connection on the green wire. Finally, down load the payload to reprogram the controller. See if the gremlins disappear.