PDA

View Full Version : Marine Power 7.4 Liter will not stay running.



Neil D
07-22-2010, 10:47 AM
Twin model S7.4V (GM 454) engines approximately 9 years old. Starboard engine starts and runs great. Port engine starts then stumbles and stalls. If you spray a little starting fluid into the air box, the engine will pickup and smooth right out. It seems like after the initial start, the engine may run out of fuel and stall. There is fuel in the tanks, and the filters have been changed. Maybe there is a permissive for the high pressure injector pump after initial 3 second initial start pump sequence, but I cannot find any literature to tell me if this is true.

makomark
07-22-2010, 10:23 PM
follow the wires from the fuel pump back into the harness. One of the leads should go to the oil pressure safety switch. They are known to fail frequently. if you find the switch, check it with a test light to see if it passes current to the pump with the engine running. If not, you can bypass the switch with a jumper lead to verify it has failed (open). Once verified, you can replace it.

If it turns out to be the switch, buy at least one spare - the other side probably got its switch from the same batch.

mountainman
08-10-2011, 12:10 AM
quadrajet carbs are known to be leakers . after a while of sitting they just loose all the fuel out of the floatbowels and then when ya go to start them they fire up initally and then die - and until they get enough fuel pumped back into the carb they will run rough as a cob . a rebuild is one answer but the q-jet will do it again ; especially if the engine sits a lot - another good reason to go with fuel injection .