PDA

View Full Version : 75hp chrysler no spark



jfaz
06-20-2009, 02:17 PM
"i have chrysler motor 75hp m#757hb,,,,s#18437 ,,(i think is 1976) compresion and fuel are good but dont have spark tell me how check the stator, i dont see the trigger if there one tell me,also the timing,coil and distributor(no points in these one) also hes a blk box reeds(ignitin system ,6cb2012a--523301)tell me how check all this wires,,tks,a lot for your help"

william_m
06-23-2009, 08:11 PM
turn on the ig with the dist wire removed. Scrape it on the block and you should hear the ignition fire under the cap. If that happens you have some shutter problems (try cleaning the lens with a q-tip).

If no spark you have amplifier box or coil problems. There is only a battery charging coil under the flywheel and the ignition is powered from the key switch.

hong_kong_force_120
06-24-2009, 01:13 PM
"I had a similar problem on a 1995 120 Force. Turned out to be an ignition switch fault, nothing wrong on the engine. If you have a 6 pin ignition switch (cold start primer type) one of the wires is the kill when the ignition is turned off (Black & yellow on mine), on other types there is a kill wire also. Try removing this wire and then starting the engine, it worked for me! I then had to use the overboard lanyard kill switch on the throttle to stop the engine or just touch the kill wire back onto its terminal. The wire will short and burn slightly as the engine dies so it is not a long term solution. I replaced the ignition switch and all is well."