PDA

View Full Version : 2GM20F load rpm problem



g_bourne
06-18-2009, 10:23 PM
"engine has 560 hrs.
engine runs smooth & clean up to 3800 rpm without load. I can't seem to get full rpm with load. max is +-2700. after that the engine knocks, puts out black smoke & loses power. prop & bottom are clean.

injectors were just serviced; valves adjusted; racor filter replaced; fuel line replaced; fuel is clean.

any ideas would be most appreciated."

direstraits
06-19-2009, 12:31 AM
hi could it be exhaust mixing elbow as these can clog or maybe air filter

g_bourne
06-19-2009, 01:22 PM
"thanks for that. the air filter is clean, but I haven't looked at the elbow yet. why would restricted exhaust cause unburnt fuel?"

direstraits
06-19-2009, 03:49 PM
"oh did you do the engine secondary filter?what sort of engine knock??when does the knock come in,what rpm and when does it go,was it there before service,on with the blocked resticted exhaust,it effects engine rpm acting like a exhaust brake and you are trying to put more fuel in but the engine can't keep up so the result is imcomplete combustion,unburnt fuel,did the engine run correctly before your changes,or was that a series of elimanations to try and get to the problem cheers grant"

g_bourne
06-19-2009, 05:40 PM
"Grant, thanks again for your feedback. I did check the secondary filter & it looks clean. I will change it anyway. the knock comes on at about 2800 while running in gear loaded & then backs off when I throttle back to 2600. the exhaust goes black when the knock comes on & then cleans up again when I throttle back. the engine ran fine up to a point 3 weeks ago when all of a sudden I couldn't get more than 900 rpm at all. since then I've been chasing down everything in the fuel system except the pumps. we found the governor screw was loose, but I'm fairly sure we got that back in place. I've had the help of a master (non-Yanmar) diesel mechanic all along. he is perplexed too... aloha, Geoff"

direstraits
06-19-2009, 08:17 PM
"secondly filter as these are very tiny and clog,it happened to me i was in the harbour under motor and going great at 3400 then all of a sudden the moter made a noise and suddenly stopped,towed in changed filters,drain water from diesel yes "water" and bled bled twice up to fuel pump then put remote on full thottle and bleed injectors,okay could check fuel tank vent,is fuel clean,could be lift pump?"

direstraits
06-19-2009, 09:19 PM
"which governor screw?was it the injection limiting screw,set by yanmar and sealed with a anti tamper wire??"

g_bourne
06-19-2009, 09:39 PM
"checked vent & it is clear. yes it was the governor set by Yanmar. the lock nut was already loose so we guessed it had moved a bit. my mechanic buddy figured out how it works & got it dialed back in. we are confident that is not the problem. I plan to change the small filter & check the elbow in the next day or 2. thanks again, Geoff"