PDA

View Full Version : Soft Bulb



tommy_mack
08-15-2006, 04:38 AM
My '83 70hp Evinrude will run at 2800rpm WOT during travel for about 20-30 mins. Then all of a sudden jump up to 4200 by itself without touching anything. Before starting I pump the primer bulb about 10 times and the bulb never gets tight.Is this my problem with the rpm's? What should I do?

haffiman37
08-15-2006, 06:43 AM
It sounds like a cylinder is not quite performing. Change the bulb and do a compression test.

junkmanted
08-15-2006, 07:47 AM
also change the ends on the gas line it maybe a bad O ring

tommy_mack
08-15-2006, 08:32 AM
Engine has less than 10 hours on a complete rebuild.

haffiman37
08-15-2006, 08:42 AM
Takes 10 minutes to ruin it running like described!

tommy_mack
08-15-2006, 09:42 AM
What should I try?

haffiman37
08-15-2006, 10:12 AM
"1: Find out which cylinder is acting up. Normally that may be read out by the plugs condition and color, to be sure no mechanical failure do a compression test.
2: When problem cylinder is located, start with a VERY close inspection of the corresponding carb. Even do an ignition test on that cylinder at the problematic RPM to be sure You have ignition.
What was the reason for the last rebuild?
Get proper fuel line and bulb. Go for OEM, too much of the 'cheap' aftermarket parts (without naming any) creates trouble. They may be used a lot of places, some are even OEM, but with different logo on, but never found equal quality of fuel lines and bulbs!"

tommy_mack
08-15-2006, 11:52 PM
The reason for the rebuild was engine sat for 3 years without running and after restarting found that it had a stuck piston.
I will invest in anew bulb and fuel line.
The mechanic that did the rebuild said that the fuel line and fittings may need to be replaced because it sounds like they are sucking air.
I continue to have carb problems even though he says he rebuilt the carbs also.