PDA

View Full Version : 350 Magnum Marine Engine not holding RPMs



plb
05-13-2008, 09:40 AM
"Good morning.

I have twin 350 Mag engs in my 310 SeaRay with inboards. Port engine is rebuilt with 40 hours on it. Last week the port engine's rpms started to flutter (surges) and I have to add throttle above 3,000 and the syncronizer gauge would flutter with the port engine. Starboard engine is fine and holds rpms. Below 2,000 rpm both engines work fine. Do you think this is a fuel concern? (i.e. water in the gas? I use the same gas for both engines and the starboard works fine. Engine temp on the port engine is good and the motor is not using oil. Any recommendations for me to check is greatly appreciated. Thank you."

bondo
05-20-2008, 06:44 AM
"Ayuh,.... Try changing the Fuel Filters...."

plb
05-20-2008, 09:59 AM
I just purchased the fuel filters.

Thank you for your reply.

concritter
05-20-2008, 05:40 PM
"My money is on you,Bondo.....surges to me usually =fuel issues.If it still continues though,I would check carb filter, and after that something stuck at checkball in pick-up line letting fuel thru, but not enough.How do I know?Last summer took me a few hours to find a piece of silicone caulk at the checkball not giving me that little bit extra to stay on plane after the bowl started to starve...Todd"

plb
05-20-2008, 06:48 PM
"Todd:

Thanks to you and Bondo for the info.

My engines are 350 Mag EFI so no Carbs involved.

Will install the new fuel/water filters tomorrow, run the boat over the weekend and let you guys know.

Thank you again for taking time to reply."